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Creating and Editing GIS Data

= Create your own data: e.g. creating new survey locations

(points), delineating new health facility catchment areas

(polygons), new roads (lines), etc.

= Edit existing datasets: e.g. adjust boundaries, move health

post locations, etc.

= |n asingle QGIS editing session you can create or edit two

different elements of a dataset:
= map data - points, lines, polygons

= Attribute data - table-based information




Data Formats: Shapefile

A common file type used in QGIS is the shapefile (.shp). Shapefiles are an ESRI vector format, made
up of several components:

Core:
bt stores the stoure formation of the featurs o] StudyArea.dbf
= shx - stores the index of the feature geometry & | StudyArea.prj
Additional: o] StudyArea.qpj
= .gpj - projection information (QGIS) .},,__ StudyArea.shp
= .qml - Style information é—,__ StudyArea.shx

= .qix - spatial index
= .prj - projection information (ESRI)
= .gmd - QGIS specific metadata



Creating a new Shapefile

Project Edit View JEWEY Settings Plugins Vector Raster Database Web Mesh SCP Processing Help ]
. (2 New Shapefile Layer X
_ Data Source Manager rl+ 2 - v D -
0 & B [ () % Dot Source M il MO e EEzE-Mmg
{g % v /? - Create Layer ’ @ New GeoPackage Layer... Ctrl+Shift+N File name
S Add Layer , New Shapefile Layer... . .
. . File encoding UTF-8 v
Embed Layers and Groups... /% New Spatialite Layer...
v v v Add from Layer Definition File... i1 New Temporary Scratch Layer... Geometry type v
Additional dimensions (@ None _ 0 Z(+ Mvalues) [ ) M values
. EPSG:4326 - WGS 84 v | A&
= To create a new shapefile go to: New Field
= |ayer > Create Layer > New Shapefile Layer ST
Type |abc Text Data v
Length |80 Precision

= New Shapefile Layer window >>>
Add to Fields List

= set the attributes and the coordinate system for the

Fields List
new datas et' Name Type Length Precision
id Integer 10
p »
= Remove Field
-a
=== OK Cancel Help




Creating a new Shapefile

Specify your dataset to be Points,
Lines or Polygons.

Create your attribute table

~

columns.
Depending on the data type you
choose you will specify field width
and precision.

Remember: shapefile attribute
names are limited to 10 characters

@ New Shapefile Layer @
File name ikalvectorGeneraliclobal_admz.shp E]
File: efite<ing |UTF-5 - |
Geometry type ’ ° Paint v]

[ tnclude Z dimension [T Include M values

[EPSG:4325 - W35 G4 76

Specify the desired
Coordinate
Reference System

Mew Field
Mame  AREA
_? Type ’Ll Decimal number T |1.2 Decimal number
Length 20 Precision & abc Text data
add to Fields List 222 Whole number
Fields List «i:5| Date
Marne Twpe Length Precision
id Integer 10
CHTRYMNAME String a0
[50 Integer 3 <
POPULATION Real 20
AREL, Real 20 fi
i | 1 | 3
Femoyve Field
04 ] ’ Cancel ] [ Help

When you click
Add to fields list
they will appear in
this window



Data Formats: Geopackage

GPKG - The default spatial data format from QGIS V3 onwards

Pros:

= Open standard, SQLite DB

=  Broad compatibility (ArcGIS, GDAL, QGIS, R, Python,...)

= Everything is contained in a single file

=  More lightweight than a real geodatabase, but just as fast

= Faster rendering, loading, panning and zooming than with shapefiles
Cons:

= Metadata not yet fully implemented

= Raster support is relatively limited

@ GeoPackage
= NGA_data.apkg

"~ blocks _kano_kaduna
.~ states_kano_kaduna
hamlet_points




Creating a new GeoPackage Layer

Specify your dataset

to be Points, Lines or —

Polygons.

Create your attribute table
fields (columns); depending
on the data type you choose
you will specify field width

and precision.

Note: GeoPackages enforce no
limit on field header characters

/

(2 New GeoPackage Layer

Database

[(® (=]

-tises|DatalDatabase\GPEG_TrainingData. gpkg E]

Table name GPEG_built_up_areas
Seomekry by ' Palygon

-

l

A

[ tnelude Z dimension [] Include M values

[EF‘SG:4326 - W33 54

New Field

y/ Mare

Type [ abe Text data

Maximurn length S0

Add ko Fields List
Fields List
Mame Tvpe Length
SettlernentMame  test an
Femove Field
P Advanced Options
(04 ] [ Zancel ] [ Help

| Palygon

Mo geometry
° Point

7 Line

#= Palygon

o MultiPoink

W MultiLine

L~ MultiPolygon
/" CompoundCurve
) CurvePolygon
W MulkiCurve

Specify the desired
Coordinate
Reference System

When you click Add
to fields list they will
appear in this
window



Start Editing

To start editing...
= Locate the Digitising toolbar:

V(/)BR*-Z i 5

= (Click a layer in the Layers panel, to make it active, and
either:

b o

= Click the Toggle editing button from the digitising toolbar
(highlighted above), or

= Right-click on the layer to select Toggle editing

.....

Houses

SR [~ Buildings

GDB_Items

=/ Survey Pointc

6&:‘ Zoom to Layer Extent

Shaow in Crverview

] Remove
|| Duplicate

Set Layer CRS
Set Project CRS from Layer

Open Attribute Table

P Toagle Editing
& Current Edits *

Save As,.,

Save Selection As, ..
Show Feature Count

Properties




Draw new features

The capture tool button (on the Digitising toolbar) will change depending on the object type of the
layer:

clicke
QQ .
. = click
* 3 clicK e
Capture points " click
xmf4 click" click
% Right-click to
Capture lines click finish drawing

clic
‘ 8\ click Right-click to
click finish drawing

Capture polygons

click



Editing: adding attribute data to features

= When you finish drawing a new feature, an

= You enter the attributes for your new feature

= You can disable this pop up in Settings, if you wish

Attribute window will pop up

Southern_Lusaka Provinces - Feature Attributes

alv

fid |Autngenerate|
Province (NVULL
layer NULL
path NULL

areakm2 NULL

OK

Cancel




Snapping (for accurate digitising)

= Use snapping to ensure that features you digitise touch/align with each other

= Due to the high precision used to store coordinates by QGIS, it is virtually impossible to exactly
capture the location of an existing feature when digitising without using snapping

= Snapping options are:

= Spnap to vertex
= Snap to segment (feature edge)

= Snap to vertex and segment




Snapping - why bother?

Polygons

Lines

Undershoot
(Dangling Node) |
|
Overshoot / )\ .
/l‘ Sliver
| Polygon



Snapping Options

Snapping options located here:
View > Toolbars > Snapping Toolbar:

Set snapping mode Follqw ad\{anced
Enable / Disable Enable topological configuration
snapping editing
\ \ / Enable tracing
& Vol 2|15 < px vv@;xﬂv“ﬁn

Set which layers to .

snap to and open >et the snappmg. Enable snapping at

advanced snapping tolerance and units i tersections

options



Topological Editing

= Topology helps minimize errors such as gaps and overlaps

= Ticking Avoid Intersections in snapping allows for quick hole filling

Project Snapping Settings n
@‘W Advanced Configuration v‘ “EQ_ Disabled v‘ | 0 v || 0 v H Y Topological Editing Hg Follow Advanced Configuration vH)‘(Snapping on Intersection H}“ Self-snapping
Layer Type Tolerance Units Avoid Overlap Min Scale Max Scale = |
v il Map data
| ® GPS_point_locations Vertex 10 pixels not set not set
|| © Southern Lusaka Hseholds finalData Vertex 12 pixels not set not set
" | topology checker Vertex 10 pixels ] not set not set
n . . [] E Advanced EZ Vertex 10 pixels ] not set not set
. . . Enumeration_Zones Vertex 12 pixels not set not set |'-

..n | Q, Filter layers... |




Topological Editing

Simple Checking

= Go to Vector > Geometry Tools > Check the

validity of the geometry.
= Select the layer and click OK

= Any errors are listed and 3 layers are created
(Valid output, Invalid output and Error

output)

Q Check Valid ty

Parameters Log

Input layer

(9 southern_Lusaka_Provinces [EPSG:4326] v Eg’] % [

Selected features only
Method
| The one selected in digitizing settings QGIS e GEOS
Ignore ring self intersections
Valid output [optional]
[Create temporary layer]
v/ QOpen output file after running algorithm
Invalid output [optional]
[Create temporary layer]
v/ QOpen output file after running algorithm
Error output [optional]
Create temporary layer]

| 0%

Run as Batch Process...

q

=]

* Check validity

This algorithm performs a validity
check on the geometries of a
vector layer.

The geometries are classified in
three groups (valid, invalid and
error), and a vector layer is
generated with the features in
each of these categories.

By default the algorithm uses the
strict OGC definition of polygon
validity, where a polygon is
marked as invalid if a self-
intersecting ring causes an interior
hole. If the "Ignore ring self
intersections” option is checked,
then this rule will be ignored and
a more lenient validity check will
be performed.

Cancel

Run | Close Help

Layers & X

0’1@1“.7“: ~5 ®HLO

® Error output
[l invalid output
B vatid output




Topological Editing

Topology checker Plugin

= Go to Menu Vector > Topology Checker

= Click on the Configuration button for adding
or deleting Topology rules.

= Add a rule, e.g. « must not overlap » to avoid
the overlaping on polygon layer.

Tool icon

|

Validate all

&
>y ¥

Topelogy Checker Panel n

\

4 ] N

Error Layer Feature 1D

Show errors Topology not checked yet

Configuration

(2 Topology Rule Settings X

Current Rules

Southern_Lusaka_Provinces ¥ | | must not overlap v
'i-i}' Add Rule | = Delete Rule

Rule Layer #1 Layer #2
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Edit Existing Features

= To edit features, first you must select it, via the

SAERAATR A"

Selection toolbar

= Then you have many options ... some are on the
Digitising toolbar:

Delete selected feature(s)

Cijt selected feature
EIE‘EF‘?'%&% 6 @

Vertex Tool - delete, move or add
vertices to lines or polygons

g

Project JZsli§ View Layer Settings Plugins

Undo

Redo

Cut Features
Copy Features
Paste Features
Paste Features As
Delete Selected
Select

”..3 Add Polygon Feature
[ty Add Circular String
("3 Add Circular String by Radius

Add Circle

Add Rectangle

Add Regular Polygon
Add Ellipse

Add Annoctation

Edit Attributes

Rotate Point Symbols
Offset Point Symbol

Ctrl+Z
Ctrl+5hift+Z

Ctrl+.

w - -  w W

Vector

<abe]

Raster Database W

PPWLLGES

§

... some are under

the Edit menu:

3 Move Feature(s)
&5, Copy and Move Feature(s)
1 Rotate Feature(s)
1 Scale Feature(s)
%, Simplify Feature
=% Add Ring
57, Add Part
&2 Fill Ring
GE Delete Ring
57 Delete Part
7 Reshape Features
@7 Offset Curve
2 Split Features
9% Split Parts
Merge Selected Features
ﬂ-_-‘ Vertex Tool (All Layers)

Reverse line

I Trim/Extend Feature




Correcting Mistakes

Use the Undo and Redo commands from the Edit menu or
the corresponding buttons from the Digitising toolbar h

The Undo / Redo window maintains a list of sequential
edits since the last save it

883

i
o
o

==
oo oo
m
oo

Clicking at a location on the list undoes or redoes edits to
that point in the list

Lindo

£ Redo



Adding/Editing Attributes

= |n the Attribute Table window, use the Toggle Editing Mode button to start/stop
editing the table or right-click the layer in the layers panel & select Toggle Editing

= Type directly into the Attribute Table

Q Southern_Lusaka_Wards — Features Total: 313, Filtered: 313, Selected: 0 — O X
G & e g LT E S D PE = e

fid District Province Ward No ConstName1 4
1 T CHILANGA LUSAKA MWEMBESHI 1 CHILANGA 207.
2 2 CHILANGA LUSAKA CHILANGA 10 CHILANGA 224,
3 3 CHILANGA LUSAKA CHINYANJA 2 CHILANGA 157.
4 b
Show All Features .




Managing Attribute Fields - Basic

= Attribute fields can be added or removed from the Attribute Table, and Layer
Properties > Fields tab

Add e Remove
Field \$ = [I_TIH Field
=R«

= To use the Add and Remove buttons, the dataset must be in edit mode (toggled
by pressing the yellow pencil button)



Managing Attribute Fields - Advanced

° Q Refactor Fields @
= The Refactor Fields tool from the ,
. . . Parameters | Log Refactor fields
Processing Toolbox provides more options
. - | |editing the structure of the
. (9 southern_Lusaka_Wards [EPSG:4326] Egj % = attributes table of a vector
§ layer. Fields can be modified
for edit your table structure it g v
Fields mapping using a fields mapping.
Source Expression Name Type Length Prec* [E :nhoe di%[l%r.ngt‘ rL?ey\er-\;;enlpits
M 0 |123fid ~ | € |fid Whole number (integer - 64bit)  ~ |0 0 figl| | generated, which contains a
[ | AI I f I d t b d d d d modified attribute table,
OWS I e S O e a e ’ remove ’ oc District ~ | | € | Distri ) - A| |according to the provided
1 |abc District District Text (string) 50 0 fields mapping.
reordered and renamed > [woroince + | [province [Toc ) o o | | ousincrane v
constraints in the template
) €| . |layer from which these fields
3 |abc Ward b4 8 Ward Text (string) ¥ |50 0 were loaded. Treat this
information as a hint during
4 |123No v € No Whole number (integer - 32bit) ¥ |0 0 configuration. No constraints
will be added on an output
. layer nor will they be
b hd -
5 |abctNamel € |ConstName1 | Text (string) 50 0 checked or enforced by the
v algorithm.
A 1.2 Araa - £ Arna Narimal nimhbar fdankla) * In n
4 »
Load fields from template layer () Advanced EZ ~* | |Load Fields
Refactored
[Create temporary layer] -
+/| Open output file after running algorithm
0% Cancel
Run as Batch Process... Run Close Help
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Field Calculator

Q Southern_lLusaka_Wards — Features Total: 313, Filtered: 313, Selected: 1 — O s u A”OWS you to re_calculate fields Or add neW
/& = L TESPR BERERE =2 8 &
@00 v |=[£][2 | Q soutrer tosaka ards — Fitd Cateaator » fields with new values such as Area and
= i /| Only update 1 selected feat Length
nly update 1 selected features
! - v/ Create a new field Update existing field
2 2/ CHILANGA Create virtual field
2 2 rHILANGA Output field name o .
‘. OutEutﬁBIdtypB Whole number (integer) v - Can aISO be applled to teXt flelds? for
==| Show All Features
A utput field length recision o o
e = =t example adding to or removing characters
Expression Function Editor
5 [ o from a text string
row_numb *
»  Aggregates
b Arrays
» Color
»  Conditional
b Conversion
b Dateand Ti
b Fields and \
=AU » Files and Pz
Feature 1 hd F : (F;;z;:;‘latcv
Preview: 4 »

OK Cancel Help
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Field Calculator

/' Attribute table - BWEA Windfarms_July07 :: Features total: 24, filtered: 24, selected: 0 [S=]=] R . .
AL CEY VIR C ——' = Calculations on numerical fields

Developer Operator Ouwner Latitude Longitude Easting Northing TurbineNum PowerMW §_ capaatymw 2

o |EnergyTech UL NIK Energy 5143 27N 0500 26 192401.2690000... | 207107.1959999... 0.500000000000... 000

13 T Tegni Tegni 5253 01N 0335 18W 293217.9330000... | 332974.7170000 1| 0.500000000000 0.500000000000000

5 T MULL ALEL 5254 01N 04 23 18w 239454.6099999. . | 335318.3420000 1| 0.850000000000 0.850000000000000 ] Ca I C u | a te a re a / I e n gt h ge O m et ry

S |Energiekontor GTO+M Co WP Mombkg . |53 08 08N 03 43 00W 285253.9170000... | 361157.3310000 1| 1.300000000000 1.300000000000000

g T Teani Teani 525401N 03 35 18W 293258.9209599... | 334828,5569935 2| 0850000000000 1,700000000000000

16 |E-ON UKRenewa _ |RES E.on Renewables |52 24 12N 03 52 56/ 272048.6150000. .| 280034, 7899953 8| 0300000000000 2.400000000000000

5 | Comni Guynt Te... |GT O+ Cwmni Gwynt Te... |53 08 08N 03 43 240 234807.9639999... | 361208, 1070000.. 2| 1,300000000000... 2,500000000000000

1 | Muon Renewables [Nuon Nuon Renewables |51 51 28N 04 34 40W 222581.3550000... | 220828.7989959.. 5[ 0.720000000000... 3.500000000000000

1 | Windjen Power Ltd |Windjen Power Ltd | Windjen Power Ltd | 5153 17 0426 430 232151.3610000... | 235000.5120000.. 3| 1.300000000000... 3.500000000000000

1g | New World Paner [RES RES 515209N 0433 25W 224060.2619999... | 222044.6250000.. 11 0.500000000000... 5.500000000000000 ‘%

[ |

— IEI
@ Field Calculator Ll_lg

. Total_Cap_Turb il
v Create a new fiekl Update existing field Query' 0.5

T How efficient is each of these 118
P windfarms, and how do they 118
1.18

2
> 1.18

05—
0.77
Answer: 0.77

Capacity MW (per wind farm) / 118

Turbine Number = Capacity per SI;

turbine 139 —
1567 |~

Only update 0 selected features

Output field type  Dedmal number (real) -

Output field length | 0 Pracision | 3 : Compare?

Expression Function Editor

| bs
- | L3
amw

:

1

v



Field Calculation - Geometry

7 Bttribute table - Defra_NUTS] :: Features total: 9, filtered: 9, selected: 0

/B R[®E6|s B8P
REF_CODE MNAME MEASURE HOTLINK

o UKF EAST MIDLANDS 15815 | WWW,STATISTIC. ..
1 UKH EAST OF ENGLAND 19575 | WWW.STATISTIC.
2 UKL LONDON 1593 | WWW.STATISTIC...
3 UKC NORTH EAST 8676 | WWW.STATISTIC. ..
4 UKD NORTH WEST 14518 | WWW.STATISTIC
5 UK SOUTH EAST 19413 | WWW,STATISTIC. ..
5 UKK SOUTH WEST 24477 | WWW. STATISTIC. ..
7 UKG WEST MIDLANDS 13004 | WWW.STATISTIC. .
3 UKE YORKSHIRE AND.. 15564 | WWW,.STATISTIC. ..

T Show All Features

7 Attribute table - Defra_NUTS1 :: Features total: 9, filtered: 9, selected: 0

EI=EIEE]

& 2P PO BIREE &
- | U date Selected
REF_CODE NAME MEASURE HOTLINK Area_m2

0 UKF EAST MIDLANDS 15815 | WWW,STATISTIC... Qﬁss?os%.og,
1 UKH EAST OF ENGLAND 19575 | WWW.STATISTIC.... 18509772862.35
5 UKI LONDOM 1595 | WWW.STATISTIC... 159052747.17
3 UKC NORTH EAST 8676 | WWW.STATISTIC... 8643343103.12
4 UKD NORTH WEST 14918 | WWW.STATISTIC... 14867133077.75
5 UK SOUTH EAST 19413 | WWW. STATISTIC... 19365281276.65
5 UKK SOUTH WEST 24477 | WWW.STATISTIC ... 24421349603.88
7 UKG WEST MIDLANDS 13004 | WWW. STATISTIC 12969039954.44
3 UKE YORKSHIRE AMD 15564 | WWW. STATISTIC 15511016493.53

T show Al Features

Q Field Calculator

[y update 0 selected features

V| Create a new field

Update existing field

Create virtual field

Output field name |Area_m2

Output field type
t field length |0

Decimal number (real)

Precision | 3

Expression Fun
[T
0|8 R Q search... Show Help | | function $area
farea » Fuzzy Matching “ | | Returns the area of the current
b General feature. The area calculated by this
~ Geometry function respects both the current
. project's ellipsoid setting and area
unit settings. For example, if an
ellipsoid has been set for the
project then the calculated area will
3 be ellipsoidal, and if no ellipsoid is
|+ - / =~ 1l ) [ e azimuth set then the calculated area will be
boundary planimetric.
Feature |1 v F bounds Syntax
Preview: 4858061648,238307 bounds_height hd P b/
You are editing information on this layer but the layer is currently not in edit mode. If you click OK, edit mode will automatically
be turned on.
oK | Cancel Help

Ensure CRS is set to UTM or some other
Map Projection

Use the function Area$ to calculate values
in the units of the CRS e.g. metres



Saving your edits

= All edits (both map features and attribute data) are saved using the Save Edits button on the
Digitising toolbar

3

?@\D‘_ﬁlﬁ'% B

Save for Selected Layer(s)

Rollback for Selected Layer(s)
Cancel for Selected Layer(s)

E Save for All Layers

G Rollback for All Layers

@ Cancel for All Layers

= Save your edits regularly as you work!
= The red pencils icon allows for speedy saving across multiple layers
=  You will be prompted to save new edits when you stop editing or try to close the programme
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Questions?

For GRID3 project updates and information, visit us online at:

@@ ID3Global (k) www.grid3.or@ www.learn.grid3.org

Or follow our partners on Twitter at @Flowminder, @WorldPopProject, @UNFPA, @PopDevUNFPA, and @CIESIN
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