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Creating and Editing Data in QGIS:  
Plotting household locations and creating survey 
areas 
 
Learning objectives: In this course we will create and edit both spatial data and attribute data, in a 
Geographic Information System. By spatial data we are referring to points, lines and polygons that 
represent real-world features (those could be road networks, locations of schools or health facilities, or 
as in this course – enumeration area boundaries). By attribute data we are referring to contextual 
information about those spatial features (e.g. survey location ID, road type, number of accidents per 
month, estimated population of a built-up area, etc., etc).   
 
Scenario: continuing the theme of course B002 (working with primary field data), you are again a survey 
planner; you are tasked with creating new and editing existing survey area boundaries as a means of 
improving ongoing surveys. 
 
By the end of this session you will be able to:   

▪ Navigate to an area using shared Spatial Bookmarks  

▪ Create a new GeoPackage and point layer 

▪ Digitise new GPS survey point locations 

▪ Add attribute data to new location points 

▪ Move existing location points 

▪ Set up snapping for accurate digitising of area polygons 

▪ Create new- and modify existing enumeration area polygons  

▪ Locate and correct topological errors in area polygons  

▪ Apply advanced digitising and error checking with Geometry Checker Plugin (optional 
section) 

▪ Apply an advanced method of data attribution to reduce errors during digitisation 
(optional section) 

▪ Manage attribute fields effectively 

▪ Use Field Calculator to calculate enumeration area (polygon) coverage 

 
Required GIS software: to complete this exercise you must have QGIS open source software installed 
on your computer. The exercise was written for QGIS version 3.22 (‘Long Term Release’ version, at 
time of writing) and for the Microsoft Windows operating system. To download QGIS, go to 
https://qgis.org/en/site/forusers/download.html and follow the installation instructions. 
 

Part 1 – Create a GeoPackage database to store new point locations 

You are planning to send survey staff to some new residential locations. Enumeration areas have been 
defined but surveyors will need a digital GPS location for each area, and which corresponds to the paper 
map they will have with them. You will create some points which could then be loaded into a GPS unit. 

https://qgis.org/en/site/forusers/download.html
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1. Open an existing QGIS project and inspect the data 

▪ Open the following QGIS project file: 

C:\G3_GIS_Training\Exercises\B003_Exercise_Creating Editing Data.qgz 

▪ Inspect the data layers, the attribute tables, zoom and pan around the map window to 
understand the data  

 

2. Import a bookmarks file and zoom to a pre-saved location 

▪ Open the Spatial Bookmarks panel if it is not already open (go to View > Panels > Spatial 
Bookmark Manager)  

▪ From the bookmark tools, click Import/Export Bookmarks 

 

▪ Select Import 

▪ Navigate to and select the following bookmarks file: 

C:\G3_GIS_Training\Exercises\Data\Bookmarks\B003_Bookmarks.xml 

▪ Click Open 

▪ You should see the following bookmarks appear: 
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▪ Either double-click New points area1 or single click then select Zoom to bookmark 
highlighted above 

▪ The map should zoom to a new location – the settlement of Itezhi-Tezhi; other data layers 
have now appeared (their visibility is controlled by Scale dependent visibility) 

 
 

3. Create a new point location layer inside a new GeoPackage 

▪ Go to Layer > Create Layer > New GeoPackage Layer 

 

▪ In the dialog box that appears complete the details as below: 
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▪ We will establish the database in the following location: 
C:\G3_GIS_Training\Exercises\Data\Output_data\GPKG_CreateEditData.gpkg 

▪ Name the new table as indicated and ensure you select point geometry 

▪ Set up a Test data field named GPS_ID with a maximum character length of 5 

▪ Now click Add to Fields List 

▪ Complete the Fields List as shown below 

▪ Expand the Advanced Options 

▪ Add a Layer Description as follows: Layer used for training to generate GPS survey 
locations 

▪ Click OK 
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▪ Your new layer GPS_point locations now appears in your Layers list; you now have an 
empty dataset in which to digitise new GPS survey points 
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Part 2 – Digitising new point locations and editing existing locations  

You can see three enumeration zones already digitised; each zone requires a point feature located within 
its boundary which could then be uploaded to a GPS and taken to the field for navigation. You will place 
the points in logical locations such as road intersections or open areas close to the centre of each zone. 
We will then move on to moving and deleting existing points.  
 

1. Digitise new point locations on the map canvas 

▪ Firstly, zoom in to the three enumeration areas 

▪ Now we will start an editing session; first, ensure that GPS_point locations is the Active 
Layer by clicking it in the Layers panel 

▪ Now locate the Digitizing Toolbar (if it is hidden, go to View > Toolbars > Digitizing 
Toolbar) 

▪ Click the pencil icon (Toggle Editing), to start editing, then click the Add Point Feature 
icon 

 

▪ Now place the first point in one of the zones by left clicking at the desired location: 

▪ A dialog box will appear – this allows you to add attribute data regarding this new point 
location; fill it in as follows: 

 

▪ Now digitise two more points in the same way for the other zones 

 

Note!  If this Feature Attributes window does not pop up, it may have been disabled in 
your QGIS settings. Go to Settings > Options… > Digitizing tab > then untick Suppress 
attribute form pop-up after feature creation:
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▪ Now open up the Attribute Table for GPS_point locations and ensure all is correct 

▪ When you have finished creating data locate the Digitizing Toolbar click Save Layer Edits: 

 

▪ Finally click the pencil icon again to Toggle Editing off  

 

 

 

 
 
We will now return to the household survey cluster locations to clean up some data errors, i.e. editing 
existing data. Some of the points in the dataset need deleting, whilst others are in the wrong location.    

2. Delete existing point locations on the map canvas 

▪ Hide the layer GPS_point locations by ticking the checkbox next to it in the Layers panel 

Challenge: 
if you have a GPS device, apply the knowledge you gained in  B001 to upload 
these new points to the device, using the GPS tools, in the Processing Toolbox 

User tip: For efficient, advanced editing look at setting up 
widgets for feature attribute classification (Layer 
Properties > Attribute Form tab) 

Challenge:  
Use the Identify tool to work out the enumeration zone ID for each area 
and use this value as the GPS_ID for your new points 
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▪ In the Spatial Bookmarks panel, go to Edit points area1 

▪ A new location appears, zoom out to orientate yourself to this location 

 
The yellow point data you can now see are part of the dataset Southern_Lusaka_ Hseholds_finalData. 
There are clearly two household location points incorrectly plotted. These are duplicates and should be 
deleted. 

▪ Ensuring that Southern_Lusaka_Hseholds_finalData is the Active Layer, start an editing 
session in the way previously described (hint: pencil icon…) 

▪ On the Selection Toolbar, locate and click the tool: Select Features by area or single click 

 

▪ Now single click one of the points; you should see a faint red cross appear in the point; it 
is now selected 

▪ Click Delete Selected on the Digitizing Toolbar: 

 

▪ Repeat for the second point 

▪ Now Save Layer Edits as before 

 

3. Move existing point locations on the map canvas 

Remaining in the same map extent, notice three points which are not located within the enumeration 
zones. We will re-locate these to a sensible location. 
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▪ Make sure you are still in editing mode 

▪ Click the Vertex Tool icon: 

 

▪ Take the cursor and hover over the point you intend to move, when the point clearly 
highlights RED, single-click the point 

▪ Now take your cursor to a location within the closest enumeration zone, and single click 
to move the point: 

 

▪ Save your edits and stop editing 
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Part 3 – Digitising new, and edit existing polygons (enumeration zones)  

We will now focus on polygon data, i.e. data that could represent enumeration zones (EZ), or built-up 
areas, neighbourhood classification blocks etc. Initially we will be adding new EZs to a dataset before 
going on to edit an existing EZ; we will use a range of digitizing tools provided by QGIS.  
 

1. Navigate to a pre-saved spatial bookmark 

▪ In your Spatial Bookmarks panel, zoom to Create_Edit_EZ 

 
 

This is an area of Lusaka, north of Emmasdale, in which somebody has been digitizing EZs (red hashed 
regions) in preparation for upcoming household surveys. The location of an enumeration zone is initially 
determined by a point location – in this case the yellow points. (The points are typically created using a 
statistical sampling process to ensure the locations are representative of the wider region.) Enumeration 
zones must also adhere to a number of important criteria: 

▪ The area must be 3 - 5 Ha (thus ensuring it is ‘walkable’ by a survey team) 

▪ EZ boundaries should not cross rivers 

▪ Roads should be used, where possible, to determine boundaries 

As you can see the digitising process in this area is incomplete; you will notice there are four point 
locations which have no corresponding EZ.  
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2. Plan the size and dimensions (i.e. 3-5 Ha) of your ‘enumeration zone’ polygon 

▪ First, zoom in to the area highlighted in yellow, above  

▪ Bring up your Measure Area tool from your Attributes Toolbar 

 

 

▪ In the dialog box that opens change the units to hectares 

 

▪ Whilst keeping the tool open, use the Measure Area tool to get a sense of the size of 3-5 
Ha in this context; study the road layout and other features 

▪ Now plan the size and dimensions of your Enumeration Zone 

 

3. Digitize a new simple polygon. 

▪ Ensuring that Enumeration_Zones is the Active Layer, start an editing session as you were 
shown earlier in this exercise 

▪ Next, click Add Polygon Feature from the Digitizing Toolbar 

 

▪ Using single left-click create your enumeration zone; when you click the final vertex, do a 
right-click anywhere on the page and the polygon will auto-complete 

▪ In the Feature Attributes window that pops up, complete the first two fields as shown: 
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▪ Click OK; your new polygon should be displayed: 

 

▪ Remember to save Layer Edits regularly, from the Editor toolbar 

 
This is very simple digitizing, i.e. creating a standalone, non-adjacent polygon. We are likely at times to 
need to create accurate adjacent polygons. For that purpose, it is essential to set up Snapping.  
 

4. Set up Snapping to ensure accurate digitising  

▪ Locate the following toolbar within your QGIS interface:  

▪ If the toolbar is not visible go to View > Toolbars > Snapping Toolbar 
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▪ From the dropdown highlighted above Click Advanced Configuration, then click Open 
Snapping Options 

 

▪ Expand the Map Data folder and tick Enumeration_Zones 

▪ Under the Type column, ensure you are snapping to vertex 

▪ Ensure that topological editing is enabled (we will look at why this is useful later on) 

▪ Finally, tick Avoid Overlap for Enumeration_Zones (on older versions, you may see ‘Avoid 
Intersections) 

 
These settings will be explained when they are made use of, in the instructions below. 
 

5. Create a new polygon feature, adjacent to an existing feature 

▪ Ensuring you are still editing, select Add Polygon Feature, from the Digitizing Toolbar 

▪ Take your cursor close to the corner vertex of the polygon below, until you see a pink 
icon appear – this indicates that snapping has identified and snapped to a vertex from your 
target dataset: 

 

▪ Left-click at this point to start digitizing your new feature, then follow the boundary of 
the polygon and left-click every pink icon (vertex snap) that you encounter along the 
boundary 
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▪ Digitise the rest of your new polygon as shown below, remember to right-click to finish 
the polygon and attributing it as follows: fid = 13, EZ_ID = EZ013 

 

▪ Now digitise a new polygon adjacent to, and to the south of this new one and attribute it 
as follows: fid = 14, EZ_ID = EZ014 
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6. Modify existing enumeration area polygon boundaries.   

We will now turn to editing existing polygons which means manipulating the individual points (or 
vertices) of existing features, in our case existing enumeration areas. We will use the vertex tool which 
enables you to either move existing vertices or create new ones. In this exercise we will refer to the map 
you georeferenced in the previous exercise. 

▪ In the Map data folder of the Layers panel, tick the box next to Gabon 
Map_georef_Arc1950 and navigate to the area pictured below  

 
 

Notice that the map highlights a number of buildings which are classed as Commercial or Mixed Use. We 
need to remove these buildings from our ‘residential’ household survey, which involved reshaping the 
polygon to exclude the buildings. 

▪ Make sure you are still editing 

▪ Select the Vertex Tool from the Digitizing toolbar  

▪ Hover your cursor over the polygon segment adjacent to Katima Mulilo Road; this 
segment will be highlighted 

Challenge:  
Investigate the ‘Tracing’ tool at  
the end of the Snapping toolbar –  
it enables you to trace an existing  
boundary without having to click  
each vertex. See if you can use it  
to digitise the new zone pictured  
here: 
 



GRID3: Creating and Editing Data in QGIS (B003)   

Page 16 of 39 
Version 3.0 

 

▪ Double-click on this line, as indicated by the cross, above 

▪ You have created a new vertex, which you can place anywhere – place it in exactly the 
same position 

▪ Now double-click on the line, a short distance to the left of your new vertex to create 
another new vertex, relocate this as indicated below 

 

▪ Continue this process until you have fully excluded the non-residential buildings 

 

▪ Click Save edits 
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7. Applying Topological Editing to edit adjacent features  

When you previously set up your Snapping settings, you enabled topological editing. This simply means 
that when you click a vertex which is on a shared boundary of two polygons, and then reposition it, it 
will adjust the boundary of both polygons, not just one. This feature means that the two features can be 
edited in sync. 

▪ In the picture above notice this shared boundary of two enumeration zones, slightly to 
the north; we will re-orientate this boundary to take in the road 

 

▪ Ensuring you are still editing, hover your cursor over the corner vertex and notice it gets 
bigger, as shown  

▪ Click the vertex and now reposition as shown below (apply the same process to the 
vertex next to it) 

 

▪ The two polygon features have adjusted in sync with each other; this is a very useful 
feature to ensure you don’t have overlaps or gaps in your digitizing 

▪ Click Save edits  

▪ Click Toggle Editing Mode to stop editing  

 

Challenge:  
When you edited the non-residential  
blocks you may have noticed a remaining  
‘residential’ building (highlighted). Go to  
the Edit drop-down menu > Edit Geometry;  
explore the tools that appear in the sub-menu 
and see if you can add a part to the  
edited Polygon…  
….this creates a multi-part polygon. 
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8. Using the Topology Checker plugin to locate errors.  

Despite the fact that the digitization was based on well-defined snapping parameters and even 
following the modification rules previously discussed, errors can still exist on the created polygons. The 
most reliable way to examine the work is using the Topology Checker plugin. 

▪ First, make sure the plugin is activated. If it's not, do it by ticking the checkbox, as shown 
below; go to the drop-down menu Plugins > Manage and Install Plugins  

▪ Search for topology in the Installed plugins 

 

▪ Once activated, click on the plugin icon.  which will appear at the top of your screen, or 
go to the drop-down menu Vector > Topology Checker 

▪ Now import the following shapefile into your map window:  

C:\G3_GIS_Training\Exercises\Data\Vector\Survey\topology_checker.shp 

▪ Hide the layers GPS_point_locations, Southern_Lusaka_Hseholds_finalData and 
Enumeration_Zones by ticking their checkbox. 

▪ Right click on the topology_checker layer and zoom to the layer; your map should look as 
follows: 
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The Topology Checker tool has several applicable rules for examining polygons; in the following 
example we will study the most common two cases. 

▪ In the Topology Checker panel, click the Configure icon  

 

▪ In the dialog box that appears, select the layer topology_checker and the rule must not have 
gaps 
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▪ Then click on Add Rule then OK 

▪ Now click on the validate all icon.  You will have as a result 3 identified errors: 

 

▪ We will then proceed to their corrections.  Activate edit mode on the topology_checker layer. 

▪ Double click on the first error, you will notice that the map zoomed directly to the error. 

▪ Untick Show errors    
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▪ Activate the vertex tool and try to bring the 3 vertices on the right to the feature on the left 

Note: best practice in topology recommends a ‘node-to-node’ relationship when dealing with adjacent 
polygons; that means there should be an identical number of vertices, ‘snapped’ to each other, along a 
shared boundary line between two polygons – so make sure you zoom in close and that you’ve enabled 
‘snap to vertex’! 

 
▪ Once done, save the changes and click Validate All again. You should have the following 

result: 

 

▪ Repeat the same for the other 2 errors 

▪ Confirm with a final validation that there are no more errors 



GRID3: Creating and Editing Data in QGIS (B003)   

Page 22 of 39 
Version 3.0 

 

▪ Now in the Topology Checker Panel , click the Configure icon 

▪ In the dialog box that appears, click on the old rule and then on Delete Rule 

▪ Under Current Rules, again select the layer topology_checker and the rule must not overlap   

▪ Then click on Add Rule and click OK 

 

▪  Again, click on Validate All. 

▪ You will have 2 errors which indicate that there are 2 overlaps in the polygons. 
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▪ Following the same method, double click on the errors and try to correct them with the vertex 
tool.  

o Hint 1 - sometimes the precise vertices which have caused the error are hard to find – 
for ‘error 0’, zoom into the central point where the three polygons meet, indicated by 
the yellow box above; you will find that one vertex is overlapping 

o Hint 2 - the remaining overlap, which is very obvious (in the northern part of the same 
polygons) requires a different approach; rather than simply moving existing vertices 
you should delete some of the existing vertices so that the remaining ones establish a 
vertex-to-vertex (or node-to-node) relationship 

▪ A final click on Validate All should display no remaining errors 

▪ Save your edits and stop editing 
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9. Advanced digitization with the Geometry Checker plugin: 

Note: this advanced section is optional 
 
There exists another plugin that performs the functions provided by Topology Checker, but it is arguably 
more powerful with a wider range of functions (however it can be tricky to run, particularly for 
newcomers. It is called the Geometry Checker. It is similar in that it checks for topology errors, but also 
for geometry validity of features. The main difference is that Geometry Checker offers an auto-
correction function which can be really useful when you can’t see some really small errors previously 
highlighted by the Topology Checker such as small overlaps and gaps.  
 

Note: auto correction is clearly very powerful and potentially a huge time-saver; however, it should 
be used with caution to ensure it is not making unwanted corrections - review the automatic 
corrections manually for validation. 

 
For the purpose of demonstration, we will use the tool to check for geometry and topology issues in 
your original Enumeration_Zones layer.  

▪ Firstly, check if the plugin is enabled by visiting Plugins > Manage and Install Plugins. Search 
for Geometry Checker. 

 

▪ To open its panel, go to the dropdown menu Vector > Check Geometries. 

▪ In the window that appears, under Input vector layers ensure that Enumeration_zones is ticked 

▪ Now confirm the Allowed geometry types (i.e. what features you want to focus on, in this 
case only polygons & multipolygons)  

▪ Next you can tick the type of geometry issues that you want to validate, e.g. by checking that 
polygons are not being self-intersected, not in self-contact, does not have duplicate nodes & 
should have more than 3 nodes; these settings are displayed below 
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▪ Now scroll down within the setup tab 

▪ You can also review the Topology checks by looking for duplicates, for features within 
other features, for overlaps & for gaps (note: for the overlaps & gaps, you can decide the 
tolerance you want based on the map units)  
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▪ Scroll further down in the setup tab window to output vector layers  

▪ you have a choice at this stage, to either modify input layer (the current live data layer in 
your project) or create a separate dataset 

▪ For now, click Modify input layers 

▪ Click on Run 

▪ You’ll now gain access to the Result tab and there you’ll find the errors discovered (in the 
Geometry check result table.  

▪ You can check each error by selecting them on the table and they’ll be highlighted and 
displayed on the map 

▪ You could manually correct the error at this stage, or you can use the auto-correction 

function by clicking on the icon  

here you should be extra careful and check results carefully! 
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We will leave this demonstration at this point, but we encourage you to explore the plug-in further, if 
you plan to incorporate it in your work or studies. 
 
In conclusion, the Geometry Checker is a powerful tool, but it must be used cautiously by experienced 
GIS users. It is often used by data managers to help with the Quality Assurance of the work done by their 
teams. We would recommend that, at least initially, its use is limited to only supervisors or a technical 
lead. 
For more information on using the plugin, visit the link:  
https://docs.qgis.org/3.22/en/docs/user_manual/plugins/core_plugins/plugins_geometry_checker.ht
ml  (support link is correct at time of writing; check QGIS for any updates to this help page) 

  

https://docs.qgis.org/3.22/en/docs/user_manual/plugins/core_plugins/plugins_geometry_checker.html
https://docs.qgis.org/3.22/en/docs/user_manual/plugins/core_plugins/plugins_geometry_checker.html
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Part 4 – Managing attribute tables and using field calculations  

We will now focus on editing within the Attribute Table. Firstly, we make changes to the table structure, 
adding and deleting fields as we need them. Secondly, we will look at generating area calculations using 
the Field Calculator application. Specifically, we will be calculating surface area (in Km2) of the 
enumeration zone polygons.  
 

1. Deleting fields in attribute tables 

▪ Open the Attribute Table for Enumeration Zones 

▪ The following fields are now surplus to requirements; locate them in your table:  

▪ Rank_Z 

▪ M_value 

▪ Click Toggle Editing to start editing 

▪ From the attribute table tools, click Delete field  

 

▪ In the Delete Fields dialog box, select the fields for deletion:  

 

▪ Click OK 

▪ Click Save edits  

▪ Click Toggle Editing Mode to stop editing 

We will now calculate the surface area in km2 of the enumeration zone polygons, but first we need to 
create a new table field to store the values 
 

2. Add new fields to attribute tables 

▪ Returning to the Attribute Table Tools, click Toggle Editing Mode then click New Field 

 

▪ In the dialog box that appears, complete as below: 
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▪ Ensure that you select Decimal number (real) for the field data Type  

3. Calculate areas of polygon features into new empty field 

▪ From the Attribute Table Tools above, click Field Calculator    

▪ In the dialog box that appears choose to Update existing field and select Area_Ha  

▪ In the middle section of the window expand the Geometry group and double-click $area 
(an in-built function which calculates surface areas of polygon features, in the current 
map unit of your project, typically square metre (m2) 

 However, we need area in hectares, and need to finish the expression to calculate this automatically.  

▪ Click the divide button , from among the mathematical operators, and then type in 
10000 to construct the following expression: $area / 10000 
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▪ Click OK. The values will now be generated in your Attribute Table – open it and check 

▪ Using the Show Statistical Summary button on the Attributes Toolbar, inspect the field 
statistics:  

 

▪ What is the smallest enumeration zone polygon?  _____________ 

▪ What is the largest? _____________ 

▪ What is the average area value for all enumeration zones? _____________ 

  

Challenge 1: Validate Calculations 
Use your Measure tool to measure some of the zone polygons and ensure that the field 
calculator measurements are correct.  

User tip: if you want to calculate areas in kilometre 
squared (km2) use $area / 1,000,000 

 Challenge 2: Digitise Road features and create a walking route 
▪ Create a new Polyline GeoPackage layer here: 

▪ C:\QGIS_Intro\Exercises\Data\Output_data\GPKG_CreateEditData.gpkg 

▪ Working in the same region, pick one of the enumeration zones and digitise a 
walking route on the roads within the zone which would enable each settlement to 
be visited 

 

▪ Ensure you use Snapping to Vertex 

▪ Create a new field in the attribute table for your roads layer 

▪ Calculate distances for every section of the walk 

▪ Use the Statistics tool to calculate the total length (sum) of your walk  
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Part 5 – Improving data attribution in QGIS using Attribute Forms 
(Advanced) 

Note: this advanced section is optional 
 
This is an advanced part where we will focus on how to manage digitisation using Attribute Forms – a 
feature found within the layer properties window. First of all, we will see how to customise field input 
values. Then, we will constrain the fields based on specific rules in order limit input errors while entering 
data.  

1. Import the shapefile Advanced_EZ.shp and review it 

▪ Go to Layer > Add Layer > Add Vector Layer and import the shapefile from: 
C:\G3_GIS_Training\Exercises\Data\Vector\Survey\Advanced_EZ.shp  

▪ Right click on the layer and Open Attribute Table 

 
 

Notice that we have 6 fields. An id field that seems to be numerical, another field named EZ_ID that has 
the name of the Enumeration zone, then location fields – province, commune and locality – and finally a 
comments field for useful notes, if there are any. 

2. Set up the “id” field to automatically increment  

Each individual polygon (or row in the table) must have a unique value in the id field. This is vital, in order 
that QGIS can uniquely identify each polygon. 
 

▪ Right-click on the Advanced_EZ layer > …Properties > Attributes Forms 

▪ Under the Available Widgets, expand the Fields and choose the id field  

▪ Expand General and make sure to uncheck “Editable” (Note: this is unchecked because 
the user should not edit this field by themself, it’ll be updated automatically) 

▪ Expand Widget Type  

▪ Choose Text Edit from the Widget Type drop-down list 
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▪ Scroll down the list and expand Constraints, make sure to check both Not null & Unique to 
ensure that anyone who edits these data in future doesn’t leave it blank, and that the value is 
unique 

▪ Now expand Defaults and click on the icon  to open the expressions dialog (check Apply 
default value on update) 
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▪ In the Expression Dialog that appears, add the function  maximum( "id" ) + 1  and click Ok 

(note: you can either type the expression in directly – it must be exactly the same as shown here 
– or expand the categories in the middle section, to auto-generate the expression)  

 



GRID3: Creating and Editing Data in QGIS (B003)   

Page 34 of 39 
Version 3.0 

 

 

3. Add rules and constraints to the EZ_ID field 

Like the id field, the EZ_ID field is another way of uniquely identifying features, however in our scenario 
EZ_ID codes relate to enumeration area specifically; they contain letters as well as numeric characters. 
The EZ_ID field was already constrained to allow only 5 characters (this is something you can do while 
creating your data for the first time, refer to Part 1 for details). We will now ensure that values entered 
for EZ_ID are unique and not left blank 

▪ Right click on the layer Advanced_EZ and go to Properties  

▪ In the Attribute Forms panel again, go to Available Widgets > Fields > click on EZ_ID 

▪ Next in the constraints widget, check the rule Not null & Unique to ensure that the 
digitizer does not leave it blank and that the value generated will be unique 

▪ Be sure to also click Enforce not null constraint and Enforce unique constraint   

▪ Click Ok 

 
 

 
 
 

4. Created a fixed value for all records in a field 

User tip: For this to work, there should be at least one polygon with an ID number 
already written manually. Otherwise, the function won’t have anything to increment 
on. It can also be avoided if you change the function to: if (maximum("id”) is NULL, 1, 
maximum("id") + 1) 
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Turning to the province field, all enumeration areas that we are digitising are in Lusaka province, 
therefore to save time and reduce potential for data entry errors, we can ensure Lusaka is entered each 
time a new area is created. 

▪ Again, right-click on the layer Advanced_EZ and go to Properties > Attributes Form 

▪ Next to, Available Widgets > Fields > click on province.  

▪ In Defaults, click again on the expression icon  

▪ In the Expression Dialog, go to Fields & Values, click on province, then click All Unique, 
and finally double click on “Lusaka” and then on Ok. 

 

▪ You’ll get back to the Attributes Form tab and here make sure to uncheck “Editable” since 
you won’t need to change it anymore and you can check “Apply default value on update” 
and click on Ok. 
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5. Finally, we will set up drop-down menu options for the fields commune & locality. 

Since there is a limited number of communes and localities in Lusaka, we can force the digitiser to select 
one of these limited options, meaning they won’t need to type it manually (and perhaps mis-spell it)! It 
is also much quicker to select a name from a menu rather than typing it out!   
 

▪ Again, right-click on the layer Advanced_EZ and go to Properties > Attributes Form 

▪ Next to, Available Widgets > Fields > click on commune.  

▪ Under Widget Type, choose the option Unique Values 

▪ Under Constraints click Not null  

▪ Now do the same for locality 
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▪ As you will soon discover, when digitising, you’ll get drop-down options like this: 

 

6. Now that you have set up your rules and constraints, digitize the Enumeration area EZ029  

▪ Make sure the layer Advanced_EZ is active and go to editing mode. 

▪ Digitize EZ029 based on the red polygon below: 
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▪ Notice that the id has been added automatically, the province is already fixed to “Lusaka” 
and if you enter “EZ028” as an EZ_ID, it will be refused and ask you to change it because it 
already exists. 

 
 

▪ You can go ahead and choose Chaisa as the commune & Emmasdale as the locality. In the 
comments field, you can write “School” since there’s a school in this area. 
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In conclusion, we have outlined a method that will make digitizing much easier and quicker for an 
individual. More Importantly however, it will ensure that they are less prone to mistakes and enforces 
greater data consistency, particularly when you have a large team working on the same data! 
 

 

User tip: 
If you have a CSV file containing data like the name of localities, you can 
upload it as a drop-down menu using the option “Value Map” under the 
Widget Type.  


